Page 1 of 1

Quest can't complete for notes with tag

Posted: Sat Jun 22, 2019 6:35 am
by SunnieLiu
Hi ARIS team,

I have been working on ARIS games for a couple of years, and I am currently designing my fifth ARIS game that's for Chinese language learning located in a Chinese university, but surprisingly, accessing Google maps isn't my biggest problem.

For a lot of the quests, I need players to create notes with different tags to avoid confusion with only the number of notes they created. However, I found that the quests can't complete by themselves after the notes with the correct tags are created. But if you leave the game and resume, you'll find the quest completed.

I initially thought it's because I'm in China, and uploading notes (text or media) to the server takes additional time or something, but I had a friend in the States tried it for me, and he said the exact same thing: quests can't complete unless you leave and resume. I then thought it's because the tags were in Chinese and they can't be recognized as fast, so I changed the tags into English, still the same. Finally, I tried a different game I made a year ago (from where I am, in China), same type of quests, but it worked: the quest completed without me having to leave game. I compared every setting, lock, trigger, etc. between these two games, everything is the same.

I'm out of my depth here, what did I do differently that made these two games react different with this type of quests? I have never run into these problem before. Could you please let me know what I need to change to make it work? Having students constantly leave game and resume really kills the fun.

Sunnie Liu

Re: Quest can't complete for notes with tag

Posted: Sun Jun 23, 2019 10:03 am
by SunnieLiu
Sorry, I figured it out: it's in the settings. Change the local evaluation -> server dependent.
Hope this post helps anyone who ever goes into this problem.