Page 1 of 1

App Crash after AR Target Recognized

Posted: Tue Jul 17, 2018 7:00 am
by lrichards29
I've been making a simple, single scene game with plaques and AR targets. Everything opens and loads properly until the camera recognizes an AR target, and then the app crashes. I'm running ARIS on iOS 11.4.1 with an iPhone 7, but I'm not sure what the problem is.


Re: App Crash after AR Target Recognized

Posted: Fri Jul 20, 2018 3:53 am
by Scortas
Hey I'm confirming this too. The app crashes as soon as it recognizes the AR target and from time to time it seems to work but this is very inconsistent. I tried to troubleshoot it in multiple ways but unfortunately was unable to find any logic behind the reason why it crashes. Was also using iphone 7 as well as iPad. I wonder what has changed since AR used to be more reliable, that is at least how I feel.

Re: App Crash after AR Target Recognized

Posted: Tue Jul 24, 2018 4:56 pm
by chrish
Sorry to say I can't replicate.

Tried just now on a game from a while back. It worked well. No crash on recognition or tap after. I'm on a iPhone 6s, iOS 11.4.1, and most recent App Store version of ARIS. I wonder if something in the creation stage has either changed or is wrong? Did you pick up on the parameter of 500(?) instead of the default 1 you need to put in to each target in vuforia? What media type are you handing off to? back in the day I had this problem with images other than jpeg, but that was fixed a while back. not that it couldn't be broken again.