Page 1 of 1

Uploading AR Targets

Posted: Thu Sep 28, 2017 1:58 pm
by pshell20
I have followed the instructions from your videos on ARIS and Vuforia and how to upload AR targets, but unfortunately I am not having any success. Here is what I have been doing - I create a target in Vuforia, download it to a zip file, and try to upload to ARIS. Every time I get an error message saying: "Cannot save ar_target: invalid contents of DB zip"

Is there something I am doing wrong?

Thank you.

Re: Uploading AR Targets

Posted: Thu Sep 28, 2017 6:25 pm
by chrish
Did you rename the zip file by any chance? I got that error when I tried to upload a renamed file.

Re: Uploading AR Targets

Posted: Mon Oct 02, 2017 3:10 pm
by djgagnon
Did that fix it? I've run into that message when I messed with the file/folder names myself.

Re: Uploading AR Targets

Posted: Thu Dec 20, 2018 9:12 am
by abunge
Hi, I am having a similar issue and hoping someone can help! I upload my targets to Vuforia and download the database. But when I go to Aris Editor -> AR Targets -> Upload AR target, I run into a problem. First, the target database does not download as a .zip file from Vuforia in the first place. Instead, for each image in the database, it downloads two separate files: a .xml and a .dat, in a folder with the same name as the target database. Trying to upload either of these files singly as an AR target gets the following error message from ARIS:

Cannot save ar_target: Invalid filetype 'dat'
Cannot save ar_target: Invalid filetype 'xml'

So, I zipped the files myself (on Mac, right clicking on the target database folder downloaded from Vuforia -> Compress)

When I try to upload the new .zip file that I created, I get a different error message:

Cannot save ar_target: Invalid DB zip

I'm not sure if this is an issue with Vuforia's download procedure or Aris's upload procedure. Any assistance is much appreciated.

Re: Uploading AR Targets

Posted: Fri Feb 08, 2019 5:28 pm
by chrish
I have a guess. When you are in Vuforia, looking at your targets within a set, there is a button at the top right to download database (all). Then choose the "android studio" option. That is what gives you the zip file. With any luck missing this button is the problem and easily remedied.

Re: Uploading AR Targets

Posted: Tue Apr 02, 2019 12:20 am
by blakefrances
I was having this problem too and was finding a lot of bugs in general actually. I was using safari and switched to chrome and it all worked fine. I had to redownload the zip file from Vuforia from chrome also.